Werk #6340

ComponentCore & Setup
TitleFixed debian agent package incompatibilities
Date2018-07-10 12:14:54
Check_MK EditionCheck_MK Raw Edition (CRE)
Check_MK Version1.4.0p35,1.6.0i1,1.5.0b9
Level1 - Trivial Change
ClassBug Fix
CompatibilityCompatible - no manual interaction needed

The debian agent package shipped with Check_MK (located in share/check_mk/agent/*.deb) was not compatible with older Debian/Ubuntu version because it used xz as compression algorithm for the control files.

When trying to install such a package an error like this occurred:

dpkg-deb: error: archive 'check-mk-agent_1.4.0p34-1_all.deb' contains not understood data member control.tar.xz, giving up

We have now changed the compression of the whole package to gzip which should make the package compatible to such systems again.