Werk #4717

ComponentAgent Bakery
TitleFixed "corrupted package" archive messages when installing DEB packages baked on SLES
Date2017-05-16 11:24:47
Check_MK EditionCheck_MK Enterprise Edition (CEE)
Check_MK Version1.4.0b8,1.5.0i1
Level1 - Trivial Change
ClassBug Fix
CompatibilityCompatible - no manual interaction needed

When installing debian agent packages baked with the Check_MK Agent Bakery running on a SLES 12 server this could lead to this message during installation:

dpkg: error processing archive check-mk-agent_1.4.0b5-88de67ef934c3774_all.deb (--install): corrupted filesystem tarfile - corrupted package archive

Background information: The tar files built into the debian package were created with a tar format that is not supported for the debian package format. We create the packages with the gnu format now on all platforms.